Andrew Havens Ruby Developer

Fixing Vagrant Chef Apache2 install errors

22 January 2013

Are you getting an error that looks like this?

[2013-01-21T19:24:34+01:00] INFO: Processing package[apache2] action install (apache2::default line 20)

Error executing action `install` on resource 'package[apache2]'

apt-get -q -y install apache2=2.2.14-5ubuntu8.9 returned 100, expected 0

Resource Declaration:
# In /tmp/vagrant-chef-1/chef-solo-1/cookbooks/apache2/recipes/default.rb

 20: package "apache2" do
 21:   package_name node['apache']['package']
 22: end

Make sure you include the apt recipe before this. It performs an apt-get update which will fix this problem.